Updating PHP for Dedicated servers

Dedicated Non-Admin Apache users

  • Non-Admin Nginx users were automatically updated to PHP 5.6 on March 14 2017.
  • Please see the instructions on how to update the PHP version you use.

DreamHost doesn't recommend switching to an admin user so you can select an older version of PHP – this could lead to your site being vulnerable to any exploit that may be out in the wild for that script and version of PHP. If your website is using a script that is not up-to-date then you run the risk of that script being compromised and malicious actions can be made on your server.

Dedicated Non-Admin Nginx users

  • Non-Admin Nginx users still use PHP 5.6.

DreamHost doesn't recommend switching to an admin user so you can select an older version of PHP – this could lead to your site being vulnerable to any exploit that may be out in the wild for that script and version of PHP. If your website is using a script that is not up-to-date then you run the risk of that script being compromised and malicious actions can be made on your server.

Admin users (Nginx and Apache)

  • Admin users (Nginx and Apache) can select the version of PHP they wish to use.
  • DreamHost recommends updating as soon as possible to PHP 5.6 or 7 since running older versions of PHP exposes your website to malicious attacks.
  • Please see the instructions on how to update the PHP version you use.

See also

Did this article answer your questions?

Article last updated .