Joomla upgrade overview and preparation

  • As of Nov 3rd 2015, all Joomla sites older than version 2.5.28 will be permanently disabled by DreamHost due to security vulnerabilities.
  • NO EXTENSIONS will be granted from this date. You must upgrade if you wish to continue using Joomla.

The following describes how to upgrade to a stable version of Joomla.

If you are no longer using your Joomla! install

You do not need to contact tech support if:

  1. You no longer use your site
  2. Domain is already hosted elsewhere or expired
  3. You no longer use the domain for any reason

Feel free to delete your Joomla! install.

Before you begin

Backup your files

Before you attempt an upgrade or data migration, please backup your site first!

You can find more information about backing up your files in the following articles:

Here's a recommended backup plug-in from the Joomla! Extensions Directory:

Determine which upgrade path to follow

Depending on the version you use, you may need to upgrade to the current version by completing several stages as Joomla! does not provide a simple upgrade path:

Your current Joomla! version Step one:
Install pre-upgrade version
Step two:
Install next version
Step three:
Install next version
Step four:
Install final version
Versions 1.0–1.0.15 Upgrade to 1.5.26 Upgrade to 2.5.6 Upgrade to 2.5.28 stable

(using the DreamHost web panel)

See Upgrading from 2.5.28 to 3.x
Versions 1.5.0–1.5.23 Upgrade to 1.5.26 Upgrade to 2.5.6 Upgrade to 2.5.28 stable

(using the DreamHost web panel)

See Upgrading from 2.5.28 to 3.x
Versions 1.5.25–1.5.26 N/A
(go to next step)
Upgrade to 2.5.6 Upgrade to 2.5.28 stable

(using the DreamHost web panel)

See Upgrading from 2.5.28 to 3.x
Version 1.6.x N/A
(go to next step)
N/A
(go to next step)
Upgrade to 2.5.28 See Upgrading from 2.5.28 to 3.x
Version 1.7.x N/A
(go to next step)
N/A
(go to next step)
Upgrade to 2.5.28 See Upgrading from 2.5.28 to 3.x
Version 2.5.x N/A
(go to next step)
N/A
(go to next step)
Upgrade to 2.5.28 stable

(using the DreamHost web panel)

See Upgrading from 2.5.28 to 3.x

See also

Migrating to Joomla! 3.x

Using a migration tool

Did this article answer your questions?

Article last updated .