EOL Debian 4.0, 5.0, and 6.0 on VPS

As of June 2016, DreamHost upgraded VPS servers running Debian Etch, Lenny, or Squeeze to Ubuntu for any NON-Admin users. Additionally, any sites running PHP versions 5.4 or lower were upgraded to PHP 5.6.

Why is the update happening?

DreamHost is updating Debian 4.0, 5.0, and 6.0 because:

  • Debian 4.0 (Etch) and 5.0 (Lenny) have already been End-Of-Lifed (EOL'd) and have stopped receiving security updates.
  • Debian 6.0 (Squeeze) was EOL'd in February 2016.

DreamHost is also updating PHP because:

  • PHP 5.3, 5.4, and 5.5 have already been EOL'd.
  • PHP 5.6 is well-tested, stable, and has been in production since August 2014.

Who is affected?

Customers running:

  • Non-Admin VPS machines running Debian Etch, Lenny, or Squeeze.

This will NOT include customers that are waiting to sign up for a DreamCompute account.

What's the time plan?

  • 05/10/16: Upgrade customers running Debian 4.0, 5.0, and 6.0 on privater servers to Ubuntu and PHP to PHP 5.6
  • 06/07/16: Upgrade delayed customers on Debian 4.0, 5.0, and 6.0 on private servers to Ubuntu and PHP to PHP 5.6

FAQs

How does this affect my PHP settings?

It's likely that older and outdated versions of PHP will no longer work after the upgrade (e.g., PHP 4, 5.2, 5.3, 5.4).

Please visit the following articles to view the latest versions at DreamHost, as well as info on how to upgrade your version:

What if I'm using an .htaccess file with rules for PHP 5.2 (or older)?

If you're using an .htaccess file to enable an older/outdated version of PHP, you must comment out those rules and convert the php.ini file into a phprc file.

The following are code examples you may see in the file:

Options +ExecCGI 
AddHandler php5-cgi .php 
Action php-cgi /cgi-bin/php-wrapper.fcgi 
Action php5-cgi /cgi-bin/php-wrapper.fcgi

Visit the following article for more information:

Will my Python and Ruby libraries also be affected?

Your custom Python installations and Ruby installations could result in errors due to outdated gems/eggs.

To fix, DreamHost recommends reinstalling the custom Python/Ruby installations (and/or gems/eggs).

Older installations of Python linked to static libraries will break. To fix, you must update your scripts so they no longer link to such libraries as these.

For example, a common linked static library is libmysql.so.l7

Your install​ should instead update to libmysql.so

For Ruby, updating/reinstalling offending gems seem to resolve the issue in most cases. For example, if the following error appears:

`require': libmysqlclient_r.so.16: cannot open shared object file: No such 
file or directory -

use the following to fix:

[server]$ gem uninstall mysql2
[server]$ gem install mysql2

What if my custom settings were originally set up by an admin user?

DreamHost recently removed admin users from VPS plans. Even though your custom settings may still work, these installations will also be removed once you are upgraded to Ubuntu.

If you have any custom settings that were originally set up by an admin user, you will need to set up such changes via a non-sudo setup.

If your configuration/installation requires sudo, you may wish to consider upgrading to DreamCompute or a dedicated server.

What can I do if I my site breaks after the upgrade?

Contact support! DreamHost will try its best to assist you in resolving the issue.

Can DreamHost help me if my site no longer works after the upgrade?

Yes, within reason.

DreamHost cannot help you directly by fixing customization issues or broken code, but will do its best to get you started in the right direction. In most cases, DreamHost can point you to any code upgrade docs and try to find any other upgrade info for software you're using.

Please visit the following article to determine the best way to reach DreamHost for support:

See also

Did this article answer your questions?

Article last updated .