Overview
This article explains how to resolve the "domain mismatch" error when connecting to a DreamHost mail server.
Resolving the error
To fix this error, you must use the correct hostname when connecting.
Cause of the error
This error occurs when using your domain's 'mail' subdomain. For example:
mail.example.com
Fixing the error
Make sure you ONLY use the DreamHost mail server name when connecting. This should be one of the following, depending on if you're using IMAP or POP to connect:
- imap.dreamhost.com
- pop.dreamhost.com
Troubleshooting
If you find that any of the above steps do not resolve the issue, try these steps:
- Remove your account completely from the 'Mail' app
- Clear out Keychain Access of *mail.dreamhost.com certificates
- Remove any saved passwords for your account.
- Reboot your Mac to flush any remaining account data from the system.
Once the machine logs back in, you can proceed to re-add your email account in Mail. If you are still experiencing connection issues after these steps, contact Apple Support for further assistance.