Parece que a tu instalación de PHP le falta la extensión de MySQL, que es requerida por WordPress

Generalidades

Al visitar tu sitio de WordPress, es posible que veas este error:

Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

Esto ocurre cuando el código PHP en tu sitio no es compatible con la versión de PHP que tu sitio está usando actualmente. Más específicamente, el problema es con la extensión obsoleta de MySQL que se eliminó a partir de PHP 7.0.

Si estás utilizando cualquier versión de PHP anterior a 7.0 y estás viendo este error, se debe a un código antiguo que debe actualizarse. Deberás actualizar los archivos principales de WordPress a la versión actual, así como cualquier complemento que esté utilizando tu sitio.

Comprueba qué versión de PHP está usando tu sitio

Primero, verifica qué versión de PHP está usando tu sitio con un archivo phpinfo.php.

Asegúrate de que coincida con la versión de PHP que muestra tu panel para tu dominio.

Si hay una discrepancia, hay una personalización potencial en algún lugar que hace que las versiones sean diferentes.

Actualizando tu código

Si tu sitio web se ha actualizado a una versión de PHP superior a 7.0 y estás viendo este error, significa que debes actualizar la versión principal de WordPress y sus complementos para usar las extensiones MySQLi o PDO_MySQL más nuevas.

Actualización de WordPress

Si has instalado WordPress como Instalación de un clic, puedes actualizarlo manualmente en tu panel, o configurarlo para que se actualice automáticamente.

Y puedes actualizar tus complementos en el tablero.

Para servidores Dedicated

Si estás en un servidor Dedicated, tu versión de MySQL puede ser 5.6. Si es así, y estás viendo este error, agrega la siguiente línea al archivo phprc de su sitio.

extension = mysql.so

Visita el siguiente artículo para obtener instrucciones sobre cómo añadir esta información:

Ver también

¿Este artículo ha respondido sus preguntas?

Última actualización el PST.